Toolbox Quickstart

GXT 툴박스는 다음의 5개 카테고리로 구성됩니다 :
벡터분석, 래스터분석, 공간통계분석, Geometry 연산 및 GeoTools 프로세스

이제 간단한 예제를 통하여 GXT 기능을 살펴보도록 하겠습니다

지도 생성 및 레이어 추가

  1. GXR 툴박스 뷰를 활성화하려면, 창 ‣ 뷰 보기 ‣ 기타... 메뉴를 실행 후 GXT 툴박스 를 선택합니다

    ../../_images/gxt_for_udig_setup_09.png
  2. 파일 ‣ 새로운 작업 ‣ 새로운 지도 메뉴를 실행하여 새로운 지도를 추가합니다

  3. 레이어 ‣ 추가... 메뉴를 실행하여 Add Data 마법사 를 불러옵니다

  4. 다음 버튼을 눌러 데이터 폴더로부터 shapefile 또는 geotiff 파일을 불러옵니다

벡터 분석

벡터 분석 툴박스는 피쳐 컬렉션(벡터 레이어)에 대한 공간 분석을 제공합니다.

  1. GXT 툴박스 뷰에서 Vector Analysis ‣ Proximity ‣ Multiple Ring Buffer 프로세스를 더블클릭합니다

  2. 필터 텍스트 입력 검색 필터에서 다음을 입력하여 분석할 프로세스를 검색할 수 있습니다: buff...

  3. Multiple Ring Buffer 프로세스는 각 피쳐에 대한 다중 버퍼를 생성하며, 거리 단위는 입력 피쳐의 좌표 체계단위를 사용합니다

  4. 필수 파라미터는 파라미터 이름 왼쪽에 녹색 원 아이콘이 표시됩니다. 파라미터에 대한 정보는 Help 탭을 확인하십시오

    ../../_images/gxt_toolbox_vector_multipleringbuffer.png
  5. 확인 버튼을 누르면 진행상태 윈도우 및 콘솔에 진행상태가 표시됩니다

  6. 분석이 완료되면 새로운 레이어가 현재 지도에 자동으로 추가됩니다

  7. 레이어 선택 후 오른쪽 마우스를 눌러 스타일 변경... 메뉴를 실행 후 스타일을 수정할 수 있습니다

    ../../_images/gxt_toolbox_vector_multipleringbuffer_style.png
  8. 스타일 수정 후 확인 버튼을 누르면 다음과 같은 레이어 스타일을 적용할 수 있습니다:

    ../../_images/gxt_toolbox_vector_multipleringbuffer_output.png

래스터 분석

래스터 분석 툴박스는 래스터 및 피쳐 컬렉션(벡터 레이어)에 대한 공간 분석을 제공합니다.

  1. GXT 툴박스 뷰에서 Raster Analysis ‣ Surface ‣ Slope 프로세스를 더블클릭합니다

  2. Slope 프로세스는 DEM과 같은 지형 데이터로부터 경사도를 분석합니다

  3. 분석할 래스터 레이어를 선택합니다

    ../../_images/gxt_toolbox_raster_slope.png
  4. 확인 버튼을 누르면 진행상태 윈도우 및 콘솔에 진행상태가 표시됩니다

  5. 분석이 완료되면 새로운 레이어가 현재 지도에 자동으로 추가됩니다.

  6. Slope, Aspect 등 많이 사용하는 분석기능의 경우 분석 결과에 적절한 심볼 스타일이 기본으로 적용됩니다

    ../../_images/gxt_toolbox_raster_slope_output.png

공간통계 분석

공간 통계 분석 툴박스는 공간 분포, 패턴, 관계 등을 분석하는 도구를 제공합니다.

  1. GXT 툴박스 뷰에서 Spatial Statistics ‣ Spatial Distribution ‣ Standard Deviational Ellipse 프로세스를 더블클릭합니다

  2. Standard Deviational Ellipse 프로세스는 포인트 등의 피쳐에 대한 공간 특성(집중정보, 방향, 분포 등)을 요약하는 표준 편차 타원체를 생성합니다.

  3. 필수 및 선택 파라미터를 입력하거나 선택합니다. 선택 파라미터는 공백으로 두면 기본값을 사용합니다

    ../../_images/gxt_toolbox_ss_sde.png
  4. 확인 버튼을 누르면 진행상태 윈도우 및 콘솔에 진행상태가 표시됩니다

  5. 분석이 완료되면 새로운 레이어가 현재 지도에 자동으로 추가됩니다.

    ../../_images/gxt_toolbox_ss_sde_output.png

Geometry 연산

Geometry 연산 툴박스는 Geometry의 관계나 연산을 시각적으로 확인할 수 있는 도구를 제공합니다.

  1. GXT 툴박스 뷰에서 Geometry ‣ Geometry ‣ ST_Buffer 프로세스를 더블클릭합니다

  2. 필수 및 선택 파라미터를 입력합니다. Help 탭에서 파라미터를 확인할 수 있습니다

  3. Geometry 입력은 WKT (Well-Known Text ) 포맷을 사용합니다

  4. 툴박스는 WKT의 유효성을 자동으로 검증하며, 오류가 있는 경우 배경색이 노란색으로 표시됩니다. 필터 등에도 유효성 검증 기능이 포함되어 있습니다

  5. endCapStyle(CAP_ROUND, 1), joinStyle(JOIN_ROUND, 1), quadrantSegments(8) 파라미터는 옵션이므로 기본값을 사용하거나 변경할 수 있습니다

    ../../_images/gxt_toolbox_geometry_buffer.png
  6. 확인 버튼을 누릅니다. 분석 결과 Geometry 역시 벡터나 래스터 데이터와 같이 레이어로 자동 추가됩니다

    ../../_images/gxt_toolbox_geometry_buffer_output.png

GeoTools 프로세스

GeoTools 프로세스는 GeoTools 라이브러리가 제공하는 gt-process 들을 사용합니다. 이 프로세스들은 GeoServer에서 WPS 프로세스들로 사용되기도 합니다.

  1. GXT 툴박스 뷰에서 GeoTools ‣ Vector processes ‣ Reproject 프로세스를 더블클릭합니다

  2. Reproject 프로세스는 좌표체계를 변환하는 프로세스입니다

  3. featurestargeCRS 를 선택합니다. ... 버튼을 눌러 좌표체계를 검색할 수 있습니다

    ../../_images/gxt_toolbox_geotools_reproject.png
  4. 확인 버튼을 누르면 진행상태 윈도우 및 콘솔에 진행상태가 표시됩니다

  5. 분석이 완료되면 새로운 레이어가 현재 지도에 자동으로 추가됩니다.

  6. uDig은 QGIS, ArcGIS처럼 on-the-fly(OTF) projection을 지원합니다

  7. GeoTools 프로세스는 다음을 참고하시기 바랍니다